在我的办公室里,仅仅提到Xerces这个词就足以煽动开发者的凶悍愤怒。粗略地看一眼其他Xerces关于SO的问题,似乎表明几乎所有Maven用户都会在某个时候“触及”这个问题。不幸的是,理解这个问题需要对Xerces的历史有一点了解…… 历史 Xerces是Java生态系统中使用最广泛的XML解析器。几乎每个用Java编写的库或框架都以某种身份使用Xerces(传递,如果不是直接的话)。 包含在官方二进制文件中的Xerces罐子直到今天还没有版本化。例如,Xerces 2.11.0实现jar是命名的xercesImpl.jar而不是xercesImpl-2.11.0.jar。 Xerces团队不使用Maven,这意味着他们不会将正式版本上传到Maven Central。 Xerces曾经作为单个jar(xerces.jar)发布,但被分成两个jar,一个包含API(xml-apis.jar),另一个包含这些API的实现(xercesImpl.jar)。许多较旧的Maven POM仍然声明依赖xerces.jar。在过去的某个时刻,Xerces也被释放了xmlParserAPIs.jar,一些较老的POM也依赖于它。 分配给xml-apis和xercesImpl的版本由那些将其jar部署到Maven存储库的人通常是不同的。例如,xml-apis可能是1.3.03版本,xercesImpl可能是2.8.0版本,即使两者都来自Xerces 2.8.0。这是因为人们经常使用它实现的规范版本标记xml-apis jar。还有就是这是一个非常不错的,但不完全击穿这里。 更复杂的是,Xerces是包含在JRE中的Java API for XML Processing(JAXP)的参考实现中使用的XML解析器。实现类在com.sun.*命名空间下重新打包,这使得直接访问它们很危险,因为它们可能在某些JRE中不可用。但是,并非所有Xerces功能都通过java.*和javax.*API 公开; 例如,没有API公开Xerces序列化。 添加到混乱的混乱中,几乎所有的servlet容器(JBoss,Jetty,Glassfish,Tomcat等)都在其一个或多个/lib文件夹中附带Xerces 。 问题 解决冲突 对于某些 – 或者可能是所有 – 上述原因,许多组织在其POM中发布和使用Xerces的自定义构建。如果你有一个小应用程序并且只使用Maven Central,这不是一个真正的问题,但它很快成为企业软件的问题,其中Artifactory或Nexus代理多个存储库(JBoss,Hibernate等): 例如,组织A可能会发布xml-apis为: <groupId>org.apache.xerces</groupId> <artifactId>xml-apis</artifactId> <version>2.9.1</version> 同时,组织B可能会发布jar如下: <groupId>xml-apis</groupId> <artifactId>xml-apis</artifactId> <version>1.3.04</version> 虽然B的jar版本低于A版jar,但Maven并不知道它们是同一个版本,因为它们有不同 groupId的版本。因此,它无法执行冲突解决,并且两个 jars都将作为已解析的依赖项包含在内: Classloader Hell 如上所述,JRE在JAXP RI中附带Xerces。虽然将所有Xerces Maven依赖项标记为<exclusion>s或as 会很好<provided>,您所依赖的第三方代码可能使用或不使用您正在使用的JDK的JAXP中提供的版本。此外,您还需要在servlet容器中提供Xerces jar以进行竞争。这给您留下了许多选择:您是否删除了servlet版本并希望您的容器在JAXP版本上运行?保留servlet版本是否更好,并希望您的应用程序框架在servlet版本上运行?如果上面列出的一个或两个未解决的冲突进入您的产品(很容易在大型组织中发生),您很快就会发现自己处于类加载器地狱,想知道类加载器在运行时选择的Xerces版本以及是否将在Windows和Linux中选择相同的jar(可能不是)。 解决方案? 我们试过标志认证的所有Xerces的Maven依赖作为<provided>或作为<exclusion>,但这是给难以执行(尤其是大型团队)的文物有这么多的别名(xml-apis,xerces,xercesImpl,xmlParserAPIs,等)。此外,我们的第三方库/框架可能无法在JAXP版本或servlet容器提供的版本上运行。 我们怎样才能最好地解决Maven的这个问题?我们是否必须对依赖关系进行这种细粒度的控制,然后依赖于分层类加载?有没有办法全局排除所有Xerces依赖项,并强制我们所有的框架/库使用JAXP版本? 更新:Joshua Spiewak已经将Xerces构建脚本的修补版本上传到XERCESJ-1454,允许上传到Maven Central。投票/观看/贡献这个问题,让我们一劳永逸地解决这个问题。   自2013年2月20日起,Maven Central 有2.11.0个JAR (以及源JAR!) xerces!参见Maven Central的Xerces。我想知道为什么他们没有解决https://issues.apache.org/jira/browse/XERCESJ-1454 … 我用过: <dependency> <groupId>xerces</groupId> <artifactId>xercesImpl</artifactId>