python – filename.whl is not supported wheel on this platform

The Question :

338 people think this question is useful

I would like to install scipy-0.15.1-cp33-none-win_amd64.whl that I have saved to local drive. I am using:

pip 6.0.8 from C:\Python27\Lib\site-packages
python 2.7.9 (default, Dec 10 2014, 12:28:03) [MSC v.1500 64 bit (AMD64)]

when I run:

pip install scipy-0.15.1-cp33-none-win_amd64.whl

I get the following error:

scipy-0.15.1-cp33-none-win_amd64.whl is not supported wheel on this platform

I would like to know what the problem is?

The Question Comments :

The Answer 1

431 people think this answer is useful

cp33 means CPython 3.3 you need scipy‑0.15.1‑cp27‑none‑win_amd64.whl instead.

The Answer 2

201 people think this answer is useful

This can also be caused by using an out-of-date pip with a recent wheel file.

I was very confused, because I was installing numpy-1.10.4+mkl-cp27-cp27m-win_amd64.whl (from here), and it is definitely the correct version for my Python installation (Windows 64-bit Python 2.7.11). I got the “not supported wheel on this platform” error.

Upgrading pip with python -m pip install --upgrade pip solved it.

The Answer 3

101 people think this answer is useful

I had the same problem while installing scipy-0.17.0-cp35-none-win_amd64.whl and my Python version is 3.5. It returned the same error message:

 scipy-0.17.0-cp35-none-win_amd64.whl is not supported wheel on this platform.

I realized that amd64 is not about my Windows, but about the Python version. Actually I am using a 32 bit Python on a 64 bit Windows. Installing the following file solved the issue:

scipy-0.17.0-cp35-none-win32.whl

The Answer 4

21 people think this answer is useful

I come across this problem because the wrong name of my package (scipy-0.17.0-cp27-none-win_amd64 (1)), after I delete the ‘(1)’ and change the package to scipy-0.17.0-cp27-none-win_amd64, the problem got resolved.

The Answer 5

19 people think this answer is useful

Change the filename to scipy-0.15.1-cp33-none-any.whl and then run this command:

pip install scipy-0.15.1-cp33-none-any.whl

It should work 🙂

The Answer 6

14 people think this answer is useful

If you are totally new to python read step by step or go directly to 5th step directly. Follow the below method to install scipy 0.18.1 on Windows 64-bit , Python 64-bit . Be careful with the versions of 1. Python 2. Windows 3. .whl version of numpy and scipy files 4. First install numpy and then scipy.

pip install FileName.whl

  1. ForNumpy:http://www.lfd.uci.edu/~gohlke/pythonlibs/#numpy ForScipy:http://www.lfd.uci.edu/~gohlke/pythonlibs/#scipy

Be aware of the file name ( what I mean is check the cp no). Ex :scipy-0.18.1-cp35-cp35m-win_amd64.whl To check which cp is supported by your pip , go to point No 2 below.

If you are using .whl file . Following errors are likely to occur .

  1. You are using pip version 7.1.0, however version 8.1.2 is available.

You should consider upgrading via the ‘python -m pip install –upgrade pip’ command

  1. scipy-0.15.1-cp33-none-win_amd64.whl.whl is not supported wheel on this platform

For the above error : start Python(in my case 3.5), type : import pip print(pip.pep425tags.get_supported())

output :

[(‘cp35’, ‘cp35m’, ‘win_amd64’), (‘cp35’, ‘none’, ‘win_amd64’), (‘py3’, ‘none’, ‘win_amd64’), (‘cp35’, ‘none’, ‘any’), (‘cp3’, ‘none’, ‘any’), (‘py35’, ‘none’, ‘any’), (‘py3’, ‘none’, ‘any’), (‘py34’, ‘none’, ‘any’), (‘py33’, ‘none’, ‘any’), (‘py32’, ‘none’, ‘any’), (‘py31’, ‘none’, ‘any’), (‘py30’, ‘none’, ‘any’)]

In the output you will observe cp35 is there , so download cp35 for numpy as well as scipy. Further edits are most welcome !!!!

The Answer 7

7 people think this answer is useful

Please do notice that all platform requirements are taken from the name of the *.whl file!

So be very careful with renaming of *.whl package. I occasionally renamed my newly compiled tensorflow package from

tensorflow-1.11.0-cp36-cp36m-linux_x86_64.whl

to

tensorflow-1.11.0-cp36-cp36m-linux_x86_64_gpu.whl

just to remind myself about gpu support and struggled with

tensorflow-1.11.0-cp36-cp36m-linux_x86_64_gpu.whl is not a supported wheel on this platform.

error for about half an hour.

The Answer 8

6 people think this answer is useful

First of all, cp33 means that it is to be used when you have Python 3.3 running on your system. So if you have Python 2.7 on your system, try installing the cp27 version.

Installing scipy-0.18.1-cp27-cp27m-win_amd64.whl, needs a Python 2.7 running and a 64-bit system.

If you are still getting an error saying “scipy-0.18.1-cp27-cp27m-win_amd64.whl is not a supported wheel on this platform”, then go for the win32 version. By this I mean install scipy-0.18.1-cp27-cp27m-win32.whl instead of the first one. This is because you might be running a 32-bit python on a 64-bit system. The last step successfully installed scipy for me.

The Answer 9

2 people think this answer is useful

I tried to install scikit-image but got the following error when I tried to install the .whl file even though my installed version of python was 2.7 32-bit. scikit_image-0.12.3-cp27-cp27m-win32.whl is not a supported wheel on this platform.

However I also got this message before the error message:

You are using pip version 7.1.0, however version 8.1.2 is available.
You should consider upgrading via the 'python -m pip install --upgrade pip' command.

I then ran the command python -m pip install --upgrade pip and then pip install scikit_image-0.12.3-cp27-cp27m-win32.whl worked fine. I hope this can help someone!

The Answer 10

2 people think this answer is useful

Things to check:

  1. You are downloading proper version like cp27 (means for python 2.7) cp36(means for python 3.6).
  2. Check of which architecture (32 bit or 64 bit) your python is? (you can do it so by opening python idle and typing)

    import platform  
    platform.architecture()
    
    

Now download the file of that bit irrespective of your system architecture.

  1. Check whether you’re using the correct filename (i.e it should not be appended with (1) which might happen if you download the file twice)

  2. Check if your pip is updated or not. If not you can use

    python -m pip install -upgrade pip

The Answer 11

2 people think this answer is useful

I’m deploying Flask using Python34 on IIS. The following steps worked for me

  1. Upgrade pip
  2. Install the wheel file for numpy
  3. pip install pandas

The Answer 12

2 people think this answer is useful

For my case with dlib installation into my python [Python 3.6.9], I have found that changing WHL file name from dlib-19.8.1-cp36-cp36m-win_amd64.whl to dlib-19.8.1-cp36-none-any.whl works for me.

Here is the way I run pip install to install dlib:

pip3 install dlib-19.8.1-cp36-none-any.whl

However, I still wonder whether there are any alternatives to install of WHL file by pip command without changing the name.

The Answer 13

1 people think this answer is useful

I had similar problem, installing a 64-bit version for python27 on windows 7 64bit. Everything was up-to-date, yet I got the message

scipy-0.18.1-cp27-cp27m-win_amd64.whl is not supported wheel on this platform

Than I donwloaded a 32-bit whl and it worked.

pip install scipy-0.18.1-cp27-cp27m-win32.whl

I suspect that the problem was probably that I dont have an AMD processor, rather and intel one, and the scipy 64bit version says amd64 in the end.

The Answer 14

1 people think this answer is useful

It’s better to check the version of python where you want to install your package. If the wheel was built for python3 and your python version is python2.x you may get this error. While installing using pip follow this convention

python2 -m pip install XXXXXX.whl #if .whl is for python2
python3 -m pip install XXXXXX.whl #if .whl is for python3

The Answer 15

0 people think this answer is useful

try conda for installation, seems to resolve versions on the fly:
conda install scikit-learn

The Answer 16

0 people think this answer is useful

Simply if you have more than one python on your system for example 2.7/3.4/3.5, it’s necessary you check your installation path. 🙂

The Answer 17

0 people think this answer is useful

I am using Python2.7 and Windows 64-bit system. I was getting the same error for lxml-3.8.0-cp27-cp27m-win_amd64.whl while doing pip install lxml-3.8.0-cp27-cp27m-win_amd64.whl Run pip install lxml and it auto-detected and successfully installed the win32 version (though my system is Windows-64bit)

C:\Python27>pip install lxml
Collecting lxml
  Downloading lxml-3.8.0-cp27-cp27m-win32.whl (2.9MB)
    100% |################################| 2.9MB 20kB/s
Installing collected packages: lxml
Successfully installed lxml-3.8.0

So, I will go with @1man’s answer.

The Answer 18

0 people think this answer is useful

During Tensorflow configuration I specified python3.6. But default python on my system is python2.7. Thus pip in my case means pip for 2.7. For me

pip3 install /tmp/tensorflow_pkg/NAME.whl

did the trick.

The Answer 19

0 people think this answer is useful

In my case [Win64, Python 2.7, cygwin] the issue was with a missing gcc.

Using apt-cyg install gcc-core enabled me to then use pip2 wheel ... to install my wheels automatically.

The Answer 20

0 people think this answer is useful

In my case it had to do with not having installed previously the GDAL core. For a guide on how to install the GDAL and Basemap libraries go to: https://github.com/felipunky/GISPython/blob/master/README.md

The Answer 21

0 people think this answer is useful

For me, it worked when I selected the correct bit of my Python version, NOT the one of my computer version.

Mine is 32bit, and my computer is 64bit. That was the problem and the 32bit version of fixed it.

To be exact, here is the one that I downloaded and worked for me:

mysqlclient-1.3.13-cp37-cp37m-win32.whl

Once again, just make sure to chose your python version of bits and not your system one.

The Answer 22

0 people think this answer is useful

I tried a bunch of the stuff above to no avail.

Previously, I upgraded to pip 18.1.

Kept getting the following error when trying (for pyFltk):

from fltk import *

ImportError: DLL load failed %1 is not a valid Win32 Application

I was getting all sorts of errors about the *.whl file not being supported by my machine or something about being unable to remove the correct files from distutils.

Went back to my notes and they indicated that the whl file:

pyFltk-1.3.3.1-cp36-cp36m-win_amd64.whl but I kept getting the error above sooo…

it required pip 9.0.3 to install.

I downgraded my version of pip to 9.0.3

pip install pip=9.0.3

and the .whl file installed properly.

This is also related to: here

The Answer 23

0 people think this answer is useful

I was trying to verify the installation of TensorFlow as specified here on a newly created virtual environment on Python 3.6. On running:

pip3 install --ignore-installed --upgrade "/Users/Salman/Downloads/tensorflow-1.12.0-cp37-cp37m-macosx_10_13_x86_64.whl"

I get the error and/or warning:

tensorflow-1.12.0-cp37-cp37m-macosx_10_13_x86_64.whl is not a supported wheel on this platform.

Since I had previously upgraded from pip to pip3, I simply replaced pip with pip3 as in:

pip3 install --ignore-installed --upgrade "/Users/Salman/Downloads/tensorflow-1.12.0-cp37-cp37m-macosx_10_13_x86_64.whl"

and it worked like a charm!

The Answer 24

0 people think this answer is useful

I had the same problem

I downloaded latest pip from https://pypi.org/project/pip/#files

and then…. pip install << downloaded file location >>

then pygame and kivy installation worked… Thanks…!!

The Answer 25

0 people think this answer is useful

cpXX indicate the python version , which ever pythonXX version you have installed into your system download that particular cpxx file.

for example if you have installed python version 3.7 then
install
packagename-packageversion-cp37-cp37m-osx_10_13_x86_64.whl

The Answer 26

-2 people think this answer is useful

Alright, the problem is easy. Tensorflow require python 3.4 – 3.7 and 64bit. I see than you’re using python 2.7.

Read the tensorflow install instructions here: https://www.tensorflow.org/install/pip

Tags:,

Add a Comment